Problem with email delivery
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 19:45 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2022 - 19:45 CST
Investigating
We are currently experiencing some issue with our email delivery. Our engineering team is aware of the issue and they are working on a fix to restore the service as soon as possible. Sorry for the inconvenience.
Posted Jan 04, 2022 - 19:39 CST
This incident affected: Email Notifications.