Issues with XRP - Ripple Network Deposits
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 21:13 UTC
Investigating
We are currently having issues with XRP - Ripple Deposits. We are investigating what is happening.
Posted Nov 22, 2021 - 20:37 UTC
This incident affected: Cryptocurrencies 🌎 (XRP (XRP)).