Issue with tusd withdrawal
Incident Report for Bitso
Resolved
This incident has been resolved .
Posted Feb 22, 2023 - 07:59 UTC
Investigating
We are experiencing issue with tusd withdrawals. Our engineering team is working on to fix this as soon as possible.
Posted Feb 22, 2023 - 02:22 UTC
This incident affected: Cryptocurrencies 🌎 (TrueUSD (TUSD)).