Bitso wallet not being displayed in web app
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 23:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 18, 2024 - 23:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2024 - 23:09 UTC
Investigating
We are experiencing issues displaying the Bitso wallet in web. Our engineering team is actively working to resolve the issue. User funds remain secure.

We apologize for any inconvenience caused.
Posted Apr 18, 2024 - 22:58 UTC
This incident affected: Bitso Website 🖥.