Problem with crypto withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 17:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 16:56 UTC
Investigating
We are having issue with multiple withdrawal services. Our engineering team is already working on to fix this issue. Sorry for the inconvenience.
Posted Apr 08, 2024 - 16:45 UTC