Intermittent delays on withdrawals TRX/Tron USDT/Tron
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 19:19 UTC
Identified
We have identified degraded performance in TRX/Tron USDT/Tron withdrawals, causing delays in completion due to an issue with a third-party service provider. Our engineering team is already working to resolve this

We apologize for the inconvenience.

If you need further assistance, do not hesitate to contact us through our Customer Support at https://support.bitso.com/
Posted Mar 20, 2024 - 16:49 UTC
This incident affected: Cryptocurrencies 🌎 (TRON (TRX)).