USDT and TRON Intermittent delays with outgoing transactions processing
Incident Report for Bitso
Resolved
Transaction processing is now flowing as expected and withdrawals have been re-enabled, this incident has been resolved.
Posted Mar 04, 2024 - 22:29 UTC
Update
We are currently experiencing a degraded performance for USDT | TRON transactions due to an issue with our 3rd party service provider. We have disabled temporarily withdrawals while the investigation is completed.
As a workaround, you can perform your withdrawals using a different network.

We apologize for the inconvenience.
Posted Mar 04, 2024 - 20:01 UTC
Identified
We are currently experiencing a degraded performance for USDT | TRON transactions due to an issue with our 3rd party service provider. Our engineering team is already working on this case.
We apologize for the inconvenience
Posted Mar 04, 2024 - 17:29 UTC
This incident affected: Cryptocurrencies 🌎 (Tether USD (Ethereum network) (USDT), TRON (TRX)).