ETH / ETH_ERC20 deposits & withdrawals temporarily disabled
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jan 06, 2022 - 19:24 CST
Identified
ETH / ETH_ERC20 deposits & withdrawals has been temporarily disabled due to an ongoing issue. It will be enabled again in some minutes. Sorry for the inconvenience.
Posted Jan 06, 2022 - 19:09 CST