Degraded performance for withdrawals on BTC,LTC,BCH & XRP

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 02:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 00:47 UTC

Identified

We are currently experiencing issues with multiple withdrawal services BTC,LTC,BCH & XRP. Our engineering team is actively working to resolve the problem.
We apologize for the inconvenience and appreciate your patience.
----------------

Estamos experimentando problemas con varios servicios de retiro BTC,LTC,BCH & XRP. Nuestro equipo de ingeniería ya está trabajando activamente para resolverlo.

Disculpa las molestias, agradecemos tu paciencia.
----------------

Estamos enfrentando problemas com vários serviços de saque BTC,LTC,BCH & XRP. Nossa equipe de engenharia já está trabalhando ativamente para resolver a situação.

Pedimos desculpas pelo transtorno e agradecemos sua paciência.
Posted Apr 18, 2025 - 00:22 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC), XRP (XRP)).