Issue with conversion

Incident Report for Bitso

Resolved

Incident has been reolved. New conversions are working fine, pending stuck conversions will be unblocked soon. Sorry for the inconvenience!
Posted Mar 10, 2025 - 11:46 UTC

Investigating

We are having issue on converion execution. Our team is working on to fix this as soon as possible.
Posted Mar 10, 2025 - 11:22 UTC