ALGO deposits disabled
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 08, 2022 - 18:52 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2022 - 17:29 CDT
Identified
ALGO deposits have been temporarily disabled. We will update once they are enabled again. For further support please reach out to our support - https://support.bitso.com/
Posted Aug 08, 2022 - 15:38 CDT
This incident affected: Cryptocurrencies 🌎 (Algorand (ALGO)).