bonk, WIF & popcat withdrawal disabled

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 09:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2025 - 08:36 UTC

Investigating

bonk, WIF & popcat withdrawal has been disabled due to an ongoing issue. It will be enabled once issue is fixed. Users fund is safe. Our engineering team is trying to fix this issue as soon as possible. Sorry for the inconvenience!
Posted Mar 12, 2025 - 07:40 UTC