Bitso.com website intermittence

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 21:00 UTC

Identified

We are currently experiencing intermittent issues with loading the Bitso webpage. Our engineering team is aware of the situation and is actively working to resolve it as quickly as possible. We appreciate your patience and understanding.
Posted Feb 10, 2025 - 19:00 UTC
This incident affected: Bitso Website 🖥.