Delay in Crypto Withdrawals | June 12th, 2025

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 19:18 UTC

Investigating

Crypto withdrawals are currently delayed due to an ongoing issue with our provider. This does not impact BTC, BCH, LTC, and XRP withdrawals. Our engineering team is working with our provider to resolve this as soon as possible.
Posted Jun 12, 2025 - 18:44 UTC