MXN deposit & withdrawal
Incident Report for Bitso
Resolved
This incident has been resolved.

Esta incidencia ha sido resuelta.
Posted Apr 13, 2022 - 09:45 CDT
Update
We are continuing to investigate this issue.

Continuamos trabajando en esta incidencia.
Posted Apr 13, 2022 - 09:35 CDT
Update
We are continuing to investigate this issue.

Continuamos trabajando en esta incidencia.
Posted Apr 13, 2022 - 09:34 CDT
Investigating
We are currently experiencing an issue with our MXN deposits & withdrawals. Our engineering team is working on to restore the service as soon as possible.

Estamos experimentando problemas con los depositos y retiros de MXN. Nuestro equipo ya está trabajando para resolver el problema.
Posted Apr 13, 2022 - 09:28 CDT
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).