APE_USD book degraded performance
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 19, 2022 - 13:07 CDT
Investigating
We are having a degraded performance for book order APE_USD. Our engineering team is already working on this.
Sorry for the inconvenience.
Posted Aug 19, 2022 - 12:19 CDT
This incident affected: Cryptocurrencies 🌎 (ApeCoin (APE)).