Degraded performance for ARS deposits and withdrawals.
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 05, 2024 - 09:34 UTC
Investigating
We are currently facing issues with ARS transactions. An update will be provided once new information is available.

We apologize for the inconvenience.

If you need further assistance, please reach out to our Customer Support team at https://support.bitso.com
Posted Jul 05, 2024 - 09:29 UTC
This incident affected: Argentine pesos (ARS) 🇦🇷 (Bank Transfer (COELSA)).