Issue with BTC , BCH and LTC withdrawals

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 10:38 UTC

Investigating

We are currently facing an issue with BTC , BCH and LTC withdrawals due to ongoing problem at third party provider end therefore withdrawals have been temporarily disabled for BTC , BCH and LTC .

Rest assured, your funds will remain secure at all times.

If you need further assistance, please contact our Customer Support team at https://support.bitso.com/.
Posted Mar 16, 2026 - 10:17 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC)).