Degraded performance for BCH withdrawals .
Incident Report for Bitso
Resolved
This incident has been resolved .
Posted Apr 14, 2023 - 10:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results .
Posted Apr 14, 2023 - 10:04 UTC
Investigating
One of our service providers is having issues on processing withdrawals for BCH therefore these transactions might take longer to complete. Our engineering team is already working with them to have service restored as soon as possible.
Posted Apr 14, 2023 - 07:27 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH)).