ADA withdrawals issue
Incident Report for Bitso
Resolved
This incident has been resolved .
Posted Apr 17, 2024 - 11:19 UTC
Investigating
We have an ongoing issue with ADA withdrawals therefore it has been temporarily disabled. Our engineering team is already working on the issue. We will keep you posted . For further assistance, please reach out to our Customer Support team at https://support.bitso.com/
Posted Apr 17, 2024 - 10:05 UTC
This incident affected: Cryptocurrencies 🌎 (Cardano (ADA)).