Problem with email delivery
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 15:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2021 - 14:56 UTC
Investigating
We are having an issue with our email service. Our engineering team is working on it to resolve it as soon as possible. We will update you through this medium once it is fixed.
Sorry for the inconvenience.
Posted Aug 13, 2021 - 14:50 UTC