Issue with ARS transactions

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 11:54 UTC

Monitoring

ARS transactions are now flowing normally and we are monitoring.
Posted Apr 16, 2026 - 11:37 UTC

Investigating

We are having a degraded performance for ARS transactions . Our team is investigating the issue to get it fixed as soon as possible.

We apologize for the inconvenience and will provide further updates shortly.

If you need further assistance, please contact our Customer Support team at https://support.bitso.com/.
Posted Apr 16, 2026 - 11:05 UTC
This incident affected: Argentine pesos (ARS) 🇦🇷 (Bank Transfer (COELSA)).