Web login failure
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 04:39 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2022 - 04:33 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2022 - 04:30 CST
Investigating
We are experiencing login failure on web for https://bitso.com/ and https://bitso.com/alpha. Our engineering team is working on to fix the issue as soon as possible. In the mean time, users can continue using services through mobile apps. Sorry for the inconvenience.
Posted Dec 14, 2022 - 04:23 CST
This incident affected: Bitso Website 🖥 and Bitso Alpha 📈.