Issue with bitso mobile app

Incident Report for Bitso

Resolved

This incident has been resolved.
The Bitso Mobile App is running seamlessly.
Posted Oct 22, 2024 - 17:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 22, 2024 - 17:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2024 - 17:11 UTC

Investigating

We are having issue with bitso mobile app. Our engineering team is review the issue to fix as soon as possible.
Posted Oct 22, 2024 - 17:03 UTC
This incident affected: Bitso Mobile 📱 and Bitso Alpha Mobile 📱.