Delays to complete USDT/tron
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 01:23 UTC
Monitoring
A fix has been implemented, we see new deposits flowing normally now.

Our engineering and operations teams are working to process the pending transactions. We will inform you once they are completed.

We appreciate your patience, thank you.
Posted Jul 23, 2024 - 00:50 UTC
Investigating
We have identified delays in the deposit completion for USDT/Tron, we are currently looking into it and will resolve it soon.

Apologizes for the inconvenience.

If you need further assistance, please reach out to our Customer Support team at https://support.bitso.com/
Posted Jul 22, 2024 - 23:52 UTC
This incident affected: Cryptocurrencies 🌎 (Tether USD (Tron network) (USDT)).