SPEI transactions are flowing normally and we are monitoring.
Posted Apr 07, 2026 - 05:31 UTC
Investigating
We are currently investigating an issue causing delays with all MXN transactions (deposits and withdrawals via SPEI). Our engineering team is working to identify the root cause and restore normal processing as quickly as possible.
We apologize for any inconvenience this may cause.
Posted Apr 07, 2026 - 04:06 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).