Stock Pricing Discrepancy

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 05:07 UTC

Identified

We are experiencing intermittence in our overnight stocks transactions. Our engineering team is actively working to reenable the service. Please be advised that all user funds are fully segregated and remain secure.

Rest assured, your funds will remain secure at all times.

If you need further assistance, please contact our Customer Support team at https://support.bitso.com/.
Posted Mar 13, 2026 - 02:31 UTC