Transaction issues on Cardano blockchain
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 16:49 UTC
Investigating
Cardano transaction processing infrastructure is currently experiencing an issue that is causing issues with finalizing transactions on Cardano blockchain. Sorry for the inconvenience!
Posted Nov 19, 2024 - 02:57 UTC
This incident affected: Cryptocurrencies 🌎 (Cardano (ADA)).