Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2022 - 10:36 UTC
Scheduled
On October 2nd 2022 starting at 10:00 AM UTC, one of our providers will have scheduled maintenance that will last 1 hour. During this period, deposits and withdrawals for ALGO, ADA, DOT, DOGE, SOL and TRX will be disabled. For further assistance, please reach out to our Customer Support team at https://support.bitso.com/ -----------------------------------------------------------------------------------
Posted Sep 21, 2022 - 13:25 UTC
This scheduled maintenance affected: Cryptocurrencies 🌎 (Algorand (ALGO), Cardano (ADA), Dogecoin (DOGE), Polkadot (DOT), Solana (SOL), TRON (TRX)).