USDT & BAL withdrawals disabled.
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jun 11, 2022 - 23:13 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2022 - 12:48 CDT
Investigating
USDT & BAL withdrawals have been disabled. We will update once they are enabled again. For further queries please reach out to our support - https://support.bitso.com/
Posted Jun 10, 2022 - 19:34 CDT
This incident affected: Cryptocurrencies 🌎 (Balancer (BAL), Tether USD (USDT)).