Delay with email notifications

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Dec 18, 2021 - 12:45 UTC

Investigating

We are experiencing some delays with email delivery. We are investigating. Sorry for the inconvenience!
Posted Dec 18, 2021 - 11:32 UTC
This incident affected: Email Notifications.