XRP deposits delayed
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Apr 27, 2022 - 00:21 UTC
Investigating
XRP deposits are delayed due to an ongoing issue. Our engineering team is working on to fix the issue as soon as possible. Sorry for the inconvenience.
Posted Apr 26, 2022 - 23:59 UTC
This incident affected: Cryptocurrencies 🌎 (XRP (XRP)).