Intermittence with xrp withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jan 06, 2022 - 10:43 CST
Investigating
We are having some intermittence with xrp withdrawals. Our engineering team is aware of the situation and they are working on to fix this as soon as possible. Withdrawals may take sometime to get completed. Sorry for the inconvenience.
Posted Jan 06, 2022 - 10:04 CST
This incident affected: Cryptocurrencies 🌎 (XRP (XRP)).