Bitso login down on web
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Mar 04, 2023 - 02:45 UTC
Update
https://bitso.com/login is working fine now. We are still working on to fix https://bitso.com/alpha/login.
Posted Mar 04, 2023 - 02:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 04, 2023 - 02:23 UTC
Update
We are still working on to fix the issue. Sorry for the inconvenience. Please keep using the mobile apps until this issue is resolved.
Posted Mar 04, 2023 - 01:34 UTC
Investigating
We are facing issue with login on web. Our engineering team is working on tho fix this as soon as possible. Users can continue using service via mobile apps.
Posted Mar 04, 2023 - 00:57 UTC
This incident affected: Bitso Website 🖥.