Delays in SPEI Transactions

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 05:17 UTC

Monitoring

SPEI Transactions are now flowing normally and we continue to monitor.
Posted Feb 04, 2026 - 05:00 UTC

Investigating

We are currently facing delays for SPEI Transactions. Our engineering team is already working on it and we will keep you posted.

Rest assured, your funds will remain secure at all times.

If you need further assistance, please contact our Customer Support team at https://support.bitso.com/.
Posted Feb 04, 2026 - 04:19 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).