Delay with btc, bch & ltc withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 14, 2024 - 05:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results .
Posted Aug 14, 2024 - 04:52 UTC
Investigating
We are currently experiencing delay in withdrawals for btc, bch & ltc. Our engineering team is already working on to fix the issue. Sorry for the inconvenience.
Posted Aug 14, 2024 - 04:09 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC)).