Issues affecting withdrawals for Bitcoin (BTC), Litecoin (LTC), Bitcoin Cash (BCH), and Ripple (XRP)

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 15:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2026 - 14:49 UTC

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 19, 2026 - 14:46 UTC

Investigating

We are currently experiencing issues affecting withdrawals for Bitcoin (BTC), Litecoin (LTC), Bitcoin Cash (BCH), and Ripple (XRP). Some withdrawal requests may be delayed. Our team is aware and actively working to restore full service. We will update this page as we learn more.

---

Actualmente estamos presentando problemas que afectan los retiros de Bitcoin (BTC), Litecoin (LTC), Bitcoin Cash (BCH) y Ripple (XRP). Algunas solicitudes de retiro podrían demorarse. Nuestro equipo ya está al tanto y trabaja activamente para restablecer el servicio por completo. Actualizaremos esta página a medida que tengamos más información.

---

No momento estamos enfrentando problemas que afetam os saques de Bitcoin (BTC), Litecoin (LTC), Bitcoin Cash (BCH) e Ripple (XRP). Algumas solicitações de saque podem sofrer atrasos. Nossa equipe já está ciente e trabalhando ativamente para restabelecer o serviço por completo. Atualizaremos esta página assim que tivermos mais informações.
Posted Aug 19, 2026 - 14:33 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC), XRP (XRP)).