Retiros temporalmente desactivados
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 08, 2018 - 00:01 CDT
Investigating
Oops! Hemos tenido que desactivar los retiros de manera temporal, estamos trabajando para reactivarlos lo antes posible. Tiempo estimado 120 minutos.
Posted 6 months ago. Jun 07, 2018 - 21:14 CDT