Degraded performance for pse/cop withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted May 03, 2023 - 21:28 UTC
Investigating
We are currently experiencing issues with pse/cop withdrawals . Our engineering team is working on it and we will keep you posted . Sorry for the inconvenience .

If you need further assistance, please reach out to our Customer Support team at https://support.bitso.com/
---------------------------------------------------------------------------------------------------------------------------------

Estamos presentando problemas con los retiros de COP. Nuestro equipo de ingeniería está trabajando para solucionar el problema. Disculpe los inconvenientes.
Si necesita mayor asistencia, por favor póngase en contacto con nuestro equipo de Customer Support a través de https://support.bitso.com/
Posted May 03, 2023 - 11:36 UTC
This incident affected: Colombian Pesos (Bank Transfer).