Email delivery delayed for some email domain
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 31, 2022 - 18:08 UTC
Monitoring
The issue has been resolved at our providers end. We are monitoring the result.
Posted Jul 31, 2022 - 14:54 UTC
Investigating
We are experiencing delayed email delivery to some specific email domain due to an ongoing issue at our providers end. We are monitoring the situation and will updated once the issue is resolved.
Posted Jul 31, 2022 - 13:54 UTC
This incident affected: Email Notifications.