Degradation on MXN withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 11, 2024 - 05:12 UTC
Update
This incident has been resolved.
Posted Jul 11, 2024 - 05:12 UTC
Investigating
We have identified issues with MXN withdrawals and are currently investigating this. Withdrawals have been temporarily disabled to apply a fix. An update will be provided once new information is available.

We apologize for the inconvenience.

If you need further assistance, please reach out to our Customer Support team at https://support.bitso.com
Posted Jul 11, 2024 - 04:43 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).