Degraded performance with order processing

Incident Report for Bitso

Resolved

This incident has been resolved .
Posted Mar 15, 2024 - 05:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 15, 2024 - 05:43 UTC

Investigating

We are having degraded performance with order processing. Our engineering team is working on to fix the issue.
Posted Mar 15, 2024 - 05:37 UTC
This incident affected: Bitso Trading Engine 🚀.