Deposits delayed
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted May 30, 2022 - 08:21 CDT
Investigating
Deposits may take some time to reflect in users wallet. Our engineering team is working on to fix this as soon as possible.
Posted May 30, 2022 - 07:38 CDT