Website https://bitso.com and https://bitso.com/alpha are down
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 02:59 CDT
Identified
Only bitso & alpha landing pages are down. Login, apis and all other functionalities are working fine. Users can use https://bitso.com/login and https://bitso.com/alpha/login to login to web.
Posted Aug 28, 2022 - 23:56 CDT
Investigating
We are having downtime on https://bitso.com and https://bitso.com/alpha. We are working on to fix this as soon as possible. Users can use bitso mobile app until this is resolved.
Posted Aug 28, 2022 - 23:14 CDT
This incident affected: Bitso Website 🖥 and Bitso Alpha 📈.