A fix has been implemented and we are monitoring the results.
Thank you for your patience. ---------------------------- Se aplicaron medidas correctivas, estamos monitoreando los resultados. Los retiros y depósitos de MXN estan siendo completados.
Agradecemos su paciencia.
Posted May 27, 2025 - 17:36 UTC
Identified
We are experiencing delays on completing withdrawals for MXN. Our engineering team is already working to restore the service at the earliest.
We apologize for the inconveniences. --------------------------------------- Se observa demoras para completar retiros de MXN. Nuestro equipo de ingeniería se encuentra trabajando para restaurar el servicio a la brevedad.
Disculpe las molestias.
Posted May 27, 2025 - 17:30 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).