Degraded performance for deposits
Incident Report for Bitso
Resolved
This issue has been resolved .
Posted Jan 25, 2023 - 10:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2023 - 03:04 UTC
Investigating
There is an issue with deposits, causing a delay to reflect on the user wallet. Our engineering team is working on fixing this issue as soon as possible.

We apologize for the inconvenience.
Posted Jan 25, 2023 - 02:20 UTC