Problem loading bitso webpage
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 08:32 CST
Update
We are continuing to investigate this issue.
Posted Jan 25, 2022 - 08:28 CST
Investigating
We are having some intermittence loading Bitso webpage. Our engineering team is aware, we are working on to fix this as soon as possible.
Posted Jan 25, 2022 - 08:27 CST
This incident affected: Bitso Website 🖥.