Degraded performance for pse/cop withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 23:43 UTC
Identified
The issue has been identified and a fix was applied. Withdrawals will be completed within the next hours.

If you need further assistance, please reach out to our Customer Support team at https://support.bitso.com/
------------------------
El incidente ha sido identificado y se aplicó la corrección pertinente. Los retiros serán completados en las siguientes horas.

Para mayor información, comuníquese con nuestro equipo de atención al cliente en https://support.bitso.com/
Posted Apr 25, 2023 - 02:10 UTC
Update
We are continuing to investigate this issue.
Posted Apr 24, 2023 - 17:32 UTC
Investigating
We are currently experiencing issues with pse/cop withdrawals . Our engineering team is working on it and we will keep you posted . Sorry for the inconvenience .
Posted Apr 24, 2023 - 08:43 UTC
This incident affected: Colombian Pesos (Bank Transfer).