Issues with Bitso Website and Apps
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 17:35 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2022 - 17:09 CDT
Investigating
We are experiencing issues with Bitso Apps and Bitso Website. Our engineering team is already working on the issue.
Sorry for the inconvenience.
Posted Jul 14, 2022 - 16:46 CDT
This incident affected: Bitso Website πŸ–₯, Bitso Mobile πŸ“±, Bitso Alpha πŸ“ˆ, and Bitso Alpha Mobile πŸ“±.