Bitso web outage
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 20:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2023 - 19:55 UTC
Update
We are continuing to work on fixing this issue. But user can continue using the platform via https://bitso.com/login , https://bitso.com/alpha/login and mobile apps.
Posted Apr 25, 2023 - 18:43 UTC
Update
Mobile app is working fine now. We are working on to bring back web as soon as possible.
Posted Apr 25, 2023 - 17:48 UTC
Update
During the investigation, we had a brief downtime on Bitso Mobile applications (Alpha and Consumer) but they are now back. We remain working to restore Bitso Web Pages.
Posted Apr 25, 2023 - 17:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2023 - 17:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2023 - 17:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2023 - 17:18 UTC
Investigating
We are facing an outage on our web page & mobile. Our engineering team is working on to fix this asap. Sorry for the inconvenience.
Posted Apr 25, 2023 - 17:00 UTC
This incident affected: Bitso Website 🖥 and Bitso Mobile 📱.